Qball's Weblog

USB Problems

Tags Grind My Gears 

This is a problem I am experience with the last 4 pc’s I had.  It randomly starts happening, it randomly goes away.

At this time I have _no_ old hw connected anymore that could have caused it:

dmesg output:

[  914.271400] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:1d.1/usb7/7-2/7-2:1.0/input/input71
[  914.317881] generic-usb 0003:046D:C508.0044: input,hidraw1: USB HID v1.10 Mouse [Logitech USB Receiver] on usb-0000:00:1d.1-2/input0
[  915.876019] usb 7-2: reset low speed USB device using uhci_hcd and address 69
[  917.660015] usb 7-2: reset low speed USB device using uhci_hcd and address 69
[  919.504013] usb 7-2: reset low speed USB device using uhci_hcd and address 69
[  921.236013] usb 7-2: reset low speed USB device using uhci_hcd and address 69
[  922.940017] usb 7-2: reset low speed USB device using uhci_hcd and address 69
[  924.608518] usb 7-2: reset low speed USB device using uhci_hcd and address 69
[  926.428018] usb 7-2: reset low speed USB device using uhci_hcd and address 69
[  928.164517] usb 7-2: reset low speed USB device using uhci_hcd and address 69
[  929.932512] usb 7-2: reset low speed USB device using uhci_hcd and address 69
[  931.144541] hub 7-0:1.0: port 2 disabled by hub (EMI?), re-enabling…
[  931.144546] usb 7-2: USB disconnect, address 69
[  931.412018] usb 7-2: new low speed USB device using uhci_hcd and address 70
[  931.609883] usb 7-2: configuration #1 chosen from 1 choice
[  931.646140] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:1d.1/usb7/7-2/7-2:1.0/input/input72
[  931.672076] generic-usb 0003:046D:C508.0045: input,hidraw1: USB HID v1.10 Mouse [Logitech USB Receiver] on usb-0000:00:1d.1-2/input0
[  933.100014] usb 7-2: reset low speed USB device using uhci_hcd and address 70
[  933.425876] usb 7-2: failed to restore interface 0 altsetting 0 (error=-71)
[  933.426704] usb 7-2: USB disconnect, address 70
[  933.696518] usb 7-2: new low speed USB device using uhci_hcd and address 71
[  933.896978] usb 7-2: configuration #1 chosen from 1 choice
[  933.917200] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:1d.1/usb7/7-2/7-2:1.0/input/input73
[  933.944582] generic-usb 0003:046D:C508.0046: input,hidraw1: USB HID v1.10 Mouse [Logitech USB Receiver] on usb-0000:00:1d.1-2/input0
[  935.388014] usb 7-2: reset low speed USB device using uhci_hcd and address 71
[  937.236514] usb 7-2: reset low speed USB device using uhci_hcd and address 71
[  939.176013] usb 7-2: reset low speed USB device using uhci_hcd and address 71
[  940.568040] hub 7-0:1.0: port 2 disabled by hub (EMI?), re-enabling…
[  940.568045] usb 7-2: USB disconnect, address 71
[  940.832010] usb 7-2: new low speed USB device using uhci_hcd and address 72
[  941.037076] usb 7-2: configuration #1 chosen from 1 choice
[  941.079588] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:1d.1/usb7/7-2/7-2:1.0/input/input74
[  941.105736] generic-usb 0003:046D:C508.0047: input,hidraw1: USB HID v1.10 Mouse [Logitech USB Receiver] on usb-0000:00:1d.1-2/input0
[  942.544011] usb 7-2: reset low speed USB device using uhci_hcd and address 72
[  944.328011] usb 7-2: reset low speed USB device using uhci_hcd and address 72
[  944.784042] hub 7-0:1.0: port 2 disabled by hub (EMI?), re-enabling…
[  944.784048] usb 7-2: USB disconnect, address 72
[  945.048012] usb 7-2: new low speed USB device using uhci_hcd and address 73
[  945.245636] usb 7-2: configuration #1 chosen from 1 choice
[  945.264659] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:1d.1/usb7/7-2/7-2:1.0/input/input75
[  945.292776] generic-usb 0003:046D:C508.0048: input,hidraw1: USB HID v1.10 Mouse [Logitech USB Receiver] on usb-0000:00:1d.1-2/input0
[  946.824014] usb 7-2: reset low speed USB device using uhci_hcd and address 73
[  948.564011] usb 7-2: reset low speed USB device using uhci_hcd and address 73
[  950.312010] usb 7-2: reset low speed USB device using uhci_hcd and address 73
[  952.024018] usb 7-2: reset low speed USB device using uhci_hcd and address 73
[  952.720043] hub 7-0:1.0: port 2 disabled by hub (EMI?), re-enabling…
[  952.720047] usb 7-2: USB disconnect, address 73
[  952.984016] usb 7-2: new low speed USB device using uhci_hcd and address 74
[  953.188768] usb 7-2: configuration #1 chosen from 1 choice
[  953.232991] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:1d.1/usb7/7-2/7-2:1.0/input/input76
[  953.256103] generic-usb 0003:046D:C508.0049: input,hidraw1: USB HID v1.10 Mouse [Logitech USB Receiver] on usb-0000:00:1d.1-2/input0
[  954.648514] usb 7-2: reset low speed USB device using uhci_hcd and address 74
[  956.432016] usb 7-2: reset low speed USB device using uhci_hcd and address 74
[  958.192516] usb 7-2: reset low speed USB device using uhci_hcd and address 74
[  959.936017] usb 7-2: reset low speed USB device using uhci_hcd and address 74
[  961.688012] usb 7-2: reset low speed USB device using uhci_hcd and address 74
[  963.544014] usb 7-2: reset low speed USB device using uhci_hcd and address 74
[  965.384515] usb 7-2: reset low speed USB device using uhci_hcd and address 74
[  967.240515] usb 7-2: reset low speed USB device using uhci_hcd and address 74

What is causing this? On one computer it was a bad cap on the motherboard causing the whole pci bus to reset, but here that isn’t the case.

ATM my keyboard is the victim, and I am constantly missing characters, or seeing them 10 times.

Q